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Figure 1:

Figure 2:

Constructing a Headlight Nose Piece

Preface

In this lesson, you will construct a headlight nose piece using TrueSurf Master.  The
completed part should look similar to Figure 1 below.

Defining the Basic Shape

First, you are going to define the basic shape of the nose piece.  The next few drawings will
be created in the front view.  

1. Load the drawing HEADLITE.CXD.

2. Click on Draw > Rectangle > Two Corners.

3. Set the -Rectangle Plane ? modifier to “view” to
ensure that the rectangle will be horizontal to the
specified front view.

4. In the front view, draw a rectangle starting at
point P1 and ending at point P2.  Use the grid
already established to help find your points.  

5. In the same view, draw a rectangle about two
units smaller than the first, but with the bottom
of the second rectangle in line with that of the
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Figure 3:

Figure 4:

first.  

6. Click on Modify > Erase Element and remove
the lines along the bottoms of the rectangles by
clicking on the bottom lines two times.

7. Click on Modify > Corner > Fillet Curve.

8. Set the modifiers as follows:

-Trim ? to “both”
-Circle Part ? to “fillet”
-Radius ? to 3

9. Click on points C1 and C2 as demonstrated in
the figure at left, to create fillets on the corners.

10. Repeat Step 8 for the corners of the smaller
rectangle, setting the -Radius ? modifier to 2. 
Your results should be the same as Figure 5.



                                                                                                                                                                                                                   
         
CADMAX TrueSurf Master Tutorial Constructing a Headlight Nose Piece   /   5

Figure 5:

Figure 6:

Creating the Outer and Inner Walls

In the next series of steps you will rotate the profile 90 degrees to create the inner and
outer walls of the headlight nose piece as shown in Figure 6.

 

11. Click on Select > Select All In and select the
entire drawing using a rubberband box.

12. Click on Draw > Surface > Rotation.

13. Set the -Angle ? modifier to 90.

14. Click on points P1 and P2 as indicated.  The
order in which you pick the points determines
the direction of the rotation.  The points that you
pick should be at the ends of the lines as shown.

Figure 6 shows the surfaces that are generated after
steps 11-14.
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Figure 7:

Figure 8:

Blending Surfaces Between the Inner and Outer Walls

A blend surface is a surface that joins previously built surfaces.  The edges of the blend
surface are guaranteed to be tangent to the edges of the surfaces to which it connects.   In
this section, you are going to do a series of blends between the inner and outer walls of the
nose piece.  You will do this by first picking the surface edges of the surfaces that you wish
to blend, and by then clicking anywhere within the Work Area to generate the blend
surface.

15. Click on Draw > Surface > Blend > 2 Surfaces.  

16. Set the -Flow lines: modifier as follows:

#U to 10
#V to 10
Surface Edge to Single Boundary

You can change these values later if you wish.

17. Click on E1 and E2 in the locations as shown,
then click anywhere in the Work Area to accept
the specified surface edges, and to generate the
blend surface between them. 

Where you click on the surface edges determines the
blend.  Therefore, pick your points in the same
location on both surface edges.  For example, either
pick both points towards the tops of the edges, or
otherwise, pick both points towards the bottoms of
the edges, as shown in Figure 7.

Clicking on the surface edges and then clicking anywhere within the Work Area gives you
the opportunity to change your mind before the blend surface is created.
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Figure 9:   CROSS BLENDED SURFACES

If you pick one point near the top of one surface edge and the other point near the bottom of
the corresponding surface edge, the blend will cross, as demonstrated in this figure.  To
undo a crossed blend surface, click on BACKSPACE three times to remove the surface and
two geometry elements.

Figure 10:

When you click on a surface edge, that edge becomes highlighted in red.  If the edge that
you pick belongs to more than one surface and the wrong surface is highlighted, click on
OTHER-SURFACE to pick the other surface shared by that edge.

If you click on the wrong side of a surface edge or on the wrong edge, click on BACKUP to
go back to your previous point.  You must use the OTHER-SURFACE and BACKUP
functions before clicking in the Work Area to generate the blend surface.

18. Click on E3 and E4 to pick your second set of
surface edges.

19. Click anywhere within the Work Area to
generate the blend surface.
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Figure 11:

Figure 12:

Figure 13:

20. Click on E5 and E6 to pick your third set of
surface edges.

21. Click anywhere within the Work Area to
generate the blend surface.

22. Click on E7 and E8 to pick your fourth set of
surface edges.

23. Click anywhere within the Work Area to
generate the blend surface.

24. Click on E9 and E10 to pick your fifth set of
surface edges.

25. Click anywhere within the Work Area to
generate the blend surface.
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Figure 14:

Figure 15:

At this point, your part should look like this one in
Figure 14.

Making the Cylindrical Opening

Now, you are going to make the cylindrical opening of the nose piece.  To do this, you will
place two circles in the front view of the object, and then sweep them through the inner
and outer walls of the part.

26. Click on Draw > Circle > Center Radius.

27. Set the modifiers as follows:

-Radius ? to 4
-Arc Plane ? to “view”

28. Using the grid as a snap aid, place a circle in the
middle of the inside wall.

29. Reset the -Radius ? modifier to 5.

30. Press Enter to place the new circle at the same
location as the first circle.

In the next few steps, you will extrude the circles through the walls of the nose piece,
thereby creating two cylinders.
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Figure 16:

Figure 17:

31. Click on Select > Select Element and click on
both of the circles in any view.

32. Click on Modify > Sweep > Linear, Surfaces.

33. Click anywhere in the drawing to place a pick up
point.

34. Type Ctrl+<Page Down> 25, then press Enter
to extrude the circles a distance of 25 in the -z
direction.

Intersecting and Cutting the Opening and the Inside Wall

Next, you are going cut the inside wall of the part at the place where it intersects with the
cylindrical opening.  You are also going to cut the opening itself, at the place where it
meets with the inside wall.  CADMAX will automatically generate any intersecting
geometry where the cylindrical opening and the wall intersects.

NOTE:  The front and side surfaces of the drawings have been removed in the following
two sections to better show you the result of each action taken.

In the next series of steps, you will cut the smaller
cylinder where it intersects the inside wall and then
cut the inside wall where it intersects the cylinder. 
You will then remove the portion of the cylinder that
extends beyond the inside wall, and the portion of
the inside wall within the cylinder, thereby creating a
hole in the inside wall.
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Figure 18:

35. Click on Select > Select > Surface.

36. Click on the inside wall in the front view to select
it.  Make sure that no other geometry elements
are within the cursor when you click.

NOTE:  You will notice that flow lines have been
added to Figure 18.  This is to better show you the
results after Intersect+cut.

37. Click on the surface of the smaller cylinder (in
the isometric view) to select it, making sure that
no geometry elements are within the cursor.

38. Click on Modify > Edit Surface >
Intersect & Cut.

39. Click on either the smaller cylinder or the inside
wall to identify it as your cutting tool.

The cutting tool does not have to be a selected surface.  When you use Intersect & Cut, all
selected surfaces will be acted upon where they intersect with the cutting tool.  In this case,
since you need to cut both the cylinder and the inside wall, both surfaces need to be
selected.  If you only wanted to cut the cylinder, then you would only select the cylinder,
and the inside wall would be your cutting tool.
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Figure 19:

As you can see from Figure 19, CADMAX cuts the inside surface of the cylinder into two
pieces where it intersects with the inside wall, and cuts the inside wall into two pieces
where it intersects with the cylinder.  CADMAX also generates the intersecting geometry
where the cylinder and the selected surface (inside wall) intersect.
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Figure 20:

Figure 21:

40. Click on Select > Unselect Element.

41. Click on surfaces S1 (in the front view) and S2
(in the isometric view) as shown, to unselect the
cylinder and the inside wall.  These are the parts
that you want to keep.

42. Click on Modify > Erase Element to remove the
smaller cylinder where it extends beyond the
inside wall, and to remove the portion of the
inside wall within the cylinder.

43. Click on Select > Clear.
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Figure 22:

Intersecting and Cutting the Opening, Inside and Outside Walls

In the previous section, you cut the inside surface of the cylinder and the inside wall.  In
this section, you will cut the larger cylinder to the inside wall.  You will also create a hole
in the outside wall where the larger cylinder would have intersected with that wall.  Again,
CADMAX automatically generates the intersecting geometry at the places where the
cutting tool and any selected surfaces intersect.

44. Click on Select > Select Element.

45. Click on the outside wall to select the surface.

46. Click on the surface of the larger cylinder to
select it.

47. Click on the inside wall of the nose piece to
select it.

48. Click on Modify > Edit Surface >
Intersect & Cut.

49. Click on the surface of the larger cylinder to
identify it as your cutting tool.

Unlike the previous case, the selection of the cutting tool is very important here.  In this
instance, the cutting tool must be the cylinder.  The cylinder is the only surface that
intersects with the inside and outside walls of the nose piece.  If you were to select one of
the walls of the nose piece as the cutting tool, you could not generate the intersection with
the other wall, since the two walls do not intersect.
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Figure 23:

In Figure 23, you can see that the cylinder is cut into three pieces where it intersects with
the two walls, and the walls are cut into two pieces where they intersect with the cylinder. 
You can also see that CADMAX generates the intersecting geometry where any selected
surfaces (the walls) intersect with the cutting tool (the cylinder).
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Figure 24:

Figure 25:

50. Click on Select > Unselect Element.

51. Click on surfaces S1, S2, and S3 as shown in
Figure 24, to unselect the outside surface of
the cylinder, the inside wall, and the outside
wall.  These are the parts that you want to
keep.

52. Click on Modify > Erase Element to remove the
cylinder from beyond the inside wall, and to
remove the wall section where the cylinder lies.

53. Click on Select > Clear.
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Figure 26:

Figure 27:

Blending the Inside and Outside Walls

If you look at the previous drawing, you can see the separation of the inside and outside
walls.  We are going to place a blend surface between the two walls, thereby joining them.

54. Click on Draw > Surface > Blend > 2 Surfaces.

55. Click on E1 and E2 as shown to pick your surface
edges.

56. Click anywhere within the Work Area to
generate the blend surface.
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Figure 28:

Figure 29:

Rounding the Front Edges of the Cylinder

Here, you will make a simple blend between the inside and outside surfaces of the cylinder.

57. Click on Draw > Surface > Blend > 2 Surfaces.

58. Click on E1 and E2 as shown to pick your
surface edges.

59. Click anywhere within the Work Area to
generate the blend surface.
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Figure 30:

Figure 31:

Creating the Floor of the Piece

In this section, we will create the “floor” of the nose piece.  To do this, we need to
generate a blend surface between the two bottom, inside edges of the piece, and then
another blend between the two bottom, outside edges of the piece.  Then, we need to make
a final blend between these two, new surfaces.

60. Click on 3D View > Dynamics > Roll.

61. Click twice on any view and roll it so that you can
see the bottom edges of the part.

62. Click on Draw > Surface > Blend > 2 Surfaces.

63. Set the -Surface Edge ? modifier to “single
boundary”.

64. Click on E1 and E2 to pick your first set of
surface edges.

65. Click anywhere within the Work Area to
generate the blend surface.

66. Click on E3 and E4 to pick your second set of
surface edges.
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Figure 32:

Figure 33:

Figure 34:

67. Click anywhere within the Work Area to
generate the blend surface.

68. Click on E1 and E2 to pick your surface edges.  

69. Click anywhere within the Work Area to
generate the blend surface.
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Figure 35:

Figure 36:

Finishing Up

Now that you’ve constructed the nose piece, there’s only one thing left to do: finish up!  If
you roll your nose piece so that you can see the bottom of the back of it, you will notice that
there is a hole in both walls.  You’re going to close the hole, and the nose piece will be
complete!

To do that, you’re going to do more surface blending, but using a new function.

70. Click on 3D View > Dynamics > Roll.

71. Click twice on any view and roll it so that you can
see the bottom of the back of the piece.

NOTE:  You will notice that the opening is bounded
by the edges of four surfaces.  To close the opening,
you will create a blended surface between the four
edges.

72. Click on Draw > Surface > Blend > 4 Surfaces.

73. Set the -Surface Edge ? modifier to “whole side”.

74. Click on E1, E2, E3, and E4, in any order, to
pick your first set of surface edges.

75. Click anywhere within the Work Area to
generate the blend surface.

76. Click on E5, E6, E7, and E8, in any order, to
pick your second set of surface edges.

77. Click anywhere within the Work Area to
generate the blend surface.
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Figure 37:

Figure 38:

Figure 37 shows the resulting blend surface.

That’s it!  You’re done!  Your headlight nose piece should look something like this:


