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Figure 1:

Constructing a Tape Dispenser

Preface

In this, your final project you will build a tape dispenser.  Your part should look like
Figure 1 below.
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Figure 2:

Figure 3:

Building the Initial Cross Sections

Since constructing this part requires some precise point placement, we thought that color
coordinating the points would ease the process.  Therefore, some steps will use both the
name of the point (P1, S1, etc.) and the color allocated to it.  You will be making the
majority of your part using the Attribute LTBLUE.  

Geometry assigned the Attribute LTBLUE may appear white on some monitiors.  You
may shade the part (in any view) using the SHADE command on 3D Page 3, in order to
see the color more clearly.  Be sure to unshade the part however, as you may be unable to
locate specific construction points while the part shaded.

To build the initial cross sections of the dispenser, you are going to construct a spline
through a set of given points, and then construct an ellipse through a second set of points.

1. Open the drawing DSPNSR.DWG.  Click on
Edit > Surface and Boolean Solids.

2. Click on Draw > Spline > Create.

3. Set the -Input Style ? modifier to “thru points”.

4. In the front view, click on points P1, P2, P3, and
P4 (the violet points), as shown in Figure 2.

5. Click on Done to accept the points for the spline.

Figure 3 shows the spline created, passing through
the points specified.



                                                                                                                                                                                                                   
         
CADMAX TrueSurf Master Tutorial Constructing a Tape Dispenser   /   3

Figure 4:

Figure 5:

6. Click on Draw > Ellipse > Center, 2 Points.

7. Set the -Attribute Name ? modifier to ‘ltblue’.

8. In the top view, click on points P1, P2, and P3
(the blue points), as shown in Figure 4.

Point P1 is the ellipse center, P2 is a point at 0
degrees, and P3 is the 90 degree point of the ellipse.

Figure 5 shows the ellipse created in the top view,
passing through the points specified.
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Figure 6:

Figure 7:

Creating the Outer Wall

To create the outer wall of the dispenser, you are going to scale and extrude the ellipse
upward, at an angle of 15 degrees from the center of the ellipse.

9. Click on Select > Select element.

10. Click on E1 to select the ellipse.

11. Click on Draw > Surface >Scale by Angle.

12. Set the -Angle ? modifier to 15.

13. In the isometric view, click on points P1 (the
base of the blue line), P2 (the top of the blue
line), and P3 (the blue point at the start of the
ellipse), as shown in Figure 7.

Points P1 and P2 define the neutral axis of the
ellipse. The distance between P1 and P2 determines
the amount by which to extrude the ellipse.  Point P3
is the point that scales at the specified angle (in this
case, 15 degrees) to the neutral axis.  The angle of all
other points is proportioned to their distance to the
neutral axis and point P3.
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Figure 8:

Figure 9:

Figure 8 shows the generation of the outer wall.

Making the Basic Shape of the Tape Cavity

In this section, you will be building the basic shape of the tape cavity.  You will place a
circle onto the outer wall that you created earlier, and then sweep that circle to create a
surface.

Looking down on the top of the dispenser, you will place a circle that represents one wall
of the cavity at the depth indicated by the dashed line in Figure 9.  The circle will be placed
in the front view.  To ensure the proper depth, you will use Set Depth to temporarily freeze
the depth in the front view.

14. Click on the Set Depth icon on the Quick Snap
tool bar or along the right edge of the display.

15. Click on the Set Depth button in the function
box.

16. In the top view, click on point P1 (the topmost
red point), as shown in Figure 9 to freeze the
depth to this point.  The -Depth Snaps? sets itself
to ‘view’.  
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Figure 10:

Figure 11:

Figure 12:

17. Click on Draw > Circle > Center Point.  

18. Set the -Circle Plane ? modifier to “view”.

19. In the front view, click on point P2 (the green
point), as shown on Figure 10.

20. Type Ctrl+84.5, then press Enter to finish the
circle.

21. Click on the Set Depth icon and set
-Depth Snaps? from “view” back to “free”.

Figure 11 shows the size and placement of your
circle. 

Using Set Depth enabled you to perform “2D like”
construction in an orthogonal view, while freezing
the depth.

22. Click on Select > Select Element.

23. Click on C1 to select the circle.

24. Click on Modify > Sweep > Linear, Surfaces.

25. Click anywhere in the drawing to choose a
pickup point.

26. Type 4rz, then press Enter, to place your put
down point.

You can replace steps 25 and 26 by using the grid in
the top view, picking any intersection as your pick up
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Figure 13:

Figure 14:

point, and then picking a point a distance of 4 in the Z axis from the pick up point.

Your model should look like Figure 13.

Filleting the Tape Cavity

To fillet the tape cavity, you are going to place a fillet between the back plane of the cavity
and the cylinder.  Then, you are going to cut and remove the excess geometry.

27. Click on View > Zoom.

28. Click on the top left and the bottom right corners
of the isometric view to zoom. 

29. Click on Select > Select Element.

30. Click on Pl1 to select the front plane.  Make sure
that you click on the surface of the plane and not
on boundary geometry.

The current view does not permit you to see the back plane of the cavity.  However, in
order to create a fillet between the back of the cavity and the cylinder, you need to be able
to select the back surface.  CADMAX provides a facility that allows you to temporarily
peel away or remove a surface so that you can work inside of the object.  This is called
“view editing”.
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Figure 15:

Figure 16:

Figure 17:

31. Click on 3D View > Erase from View.

32. Click anywhere within the isometric view to
remove the selected surface.  Now the front
plane has been removed, permitting you to see
the back of the cavity, as shown in Figure 15.

33. Click on Clear.

34. Click on Modify > Corner > Fillet 2 Surfaces.

35. Set the -Radius? modifier to 1.

36. Click on S1 (the back plane) and S2 (the
cylinder), as shown in Figure 16.  When you click
on the surfaces, make sure that there is no
geometry inside of the cursor. 

Figure 17 shows the resulting fillet and its location.
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Figure 18:

Figure 19:

In the next series of steps, you will cut the back plane
of the cavity where it intersects with the fillet, and
then remove the portion of the plane that is outside
of the fillet edge.

37. Click on Select > Select Element.

38. Click on Pl1 to select the back plane.  Make sure
that you click fully on the back plane, and that no
geometry is inside the cursor.

39. Click on Modify > Edit Surface > Cut.  This
cuts the selected surface into two surfaces where
it intersects with the fillet.  You will know that
the cut is successful because you will see two
“P’s”, indicating that the single surface is now
two surfaces.

40. Click on Select > Unselect Element.

41. Click on PL1 to unselect the inner back plane,
leaving selected the surface outside of the fillet.

42. Click on Modify > Erase Element.

43. Click on Select > Clear.
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Figure 20:

Figure 21:

Filleting the Other Side of the Tape Cavity

To fillet the other side of the tape cavity, you are going to follow the same procedure as in
the previous section.  In this case, however, you have first to replace the front plane that
you removed from view earlier.  You will place a fillet between the front plane and the
cylinder, and then cut and remove the excess geometry.

44. Click on Select > Select > Attached Surfaces.

45. Click on C1 to select the front circle and all of
the surfaces attached to the front circle.

46. Click on 3DView > Add to View.

47. Click on the isometric view to restore the front
plane that you removed from view earlier.
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Figure 22:

Figure 23:

48. Click on Modify > Corner > Fillet 2 Surfaces.

49. Set the -Radius ? modifier to 1.

50. Click on S1 (the front plane) and S2 (the
cylinder), as shown in Figure 22.

Figure 23 shows the resulting fillet.

In the final sequence to create the cavity, the front plane must be cut where it intersects
the fillet, and the cylinder must be cut in two places where it intersects the two fillets. 
Then the excess surfaces must be removed.
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Figure 24:

Figure 25:

51. Click on Select > Select > Boundaries of
Selected Surfaces.

52. Click on Modify > Edit Surfaces > Cut to cut
the selected surfaces where they intersect with
the fillets.

53. Click on Select > Unselect Element.

54. Click on S1 and S2 to unselect the inner cylinder
and the inner plane respectively, as shown in
Figure 24.

55. Click on Modify > Erase Element.

56. Click on Select > Clear.

57. Click on View > Show Largest Fast.

Figure 25 shows the tape cavity after removing the
excess geometry.
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Figure 26:

Figure 27:

Completing the Basic Shape

Now, you are going to complete the basic shape of your tape dispenser.  First, you will
create the second, outer wall by making a mirror copy of the first wall.  Then, you will
place a surface over the top of the dispenser, effectively joining the two walls.

58. Click on Select > Select Element.

59. Click on S1 to select the outer wall.

60. Click on Modify > Mirror.

61. Set the -Move Which ? modifier to “copy”.

62. Click on point P1 in the top view, as shown in
Figure 27, to place the mirrored copy of the
outer wall.

63.  Click on Select > Clear.
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Figure 28:

Figure 29:

Figure 30:

Figure 28 shows the placement of the outer wall.

64. Click on Select > Select Element.

65. Click on E1 and E2 to select the ellipses at the
tops of the outer walls.

66. Click on Draw > Surface > Simple, the click on
Finish in the Make Surfaces function box.

Figure 30 shows the resulting surface.
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Figure 31:

Figure 32:

Creating the Dispenser Base

Now, you’re ready to use the spline that you created in step 1.  The spline is a profile of the
top edge of the dispenser.  In the next series of steps, you will extrude the spline through
the base, and then remove all of the excess geometry above the extruded spline to form the
tape dispenser.

67. Click on  Select > Select Element.

68. Click on Sp1 to select the violet spline.

69. Click on Draw > Surface >Extrusion.

70. Working in the top view, click on a pick up point
on the grid in line with the spline, as shown in
Figure 32.

71. Click on a put down point on the opposite side of
the base, in a straight direction from the pick up
point, as shown in Figure 32.
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Figure 33:

Figure 34:

Figure 33 shows the resulting surface of the extruded
spline through the basic shape of the dispenser.

Your dispenser is almost finished!  Now, you have to remove the excess geometry from the
basic shape.  Using the extruded spline surface that you created in the previous section, you
will intersect and trim the basic shape, then erase the unnecessary geometry.

72. Click on Select > Select > Geometry Attribute.

73. Set the -Attribute Name ? modifier to ltblue.

74. Click on Modify >Edit Surface > Intersect
& Trim.

75. Click on the extruded spline surface to choose it
as your cutting tool.  The boundary of the surface
will be highlighted in red, indicating that you
have selected that surface as the cutting tool.
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Figure 35:

Figure 36:

76. In the front view, click on any point below the
extruded spline surface to indicate that you want
to keep all of the geometry below the surface.

77. Once CADMAX processes the geometry, click
on Modify > Erase Element to remove all of the
geometry above the extruded surface.

78. Click on Select > Clear.

At this point, your part should appear like Figure 36. 
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Figure 37:

Figure 38:

Finishing: Keeping the Sectioned Proportions

All you have to do now, is perform one more cut using the violet extruded surface, erase a
small amount of geometry, and you have your tape dispenser!

79. Click on Select > Select > Single Surface.

80. Click on S1 to select the extruded surface.

81. Click on Modify > Edit Surface > Cut to cut the
surface where it intersects with the base and the
cavity.

82. Click on Select > Unselect > Surface.

83. Click on S2 to unselect the portion of the surface
that you want to keep.

84. Click on Modify > Erase Element.

85. Click on Select > Clear.
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Figure 39:

Your tape dispenser is finished!  For fun, you can try adding the spool and tape.  Your
dispenser should look like Figure 39 below.


