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Assembly-in-Place Tutorial

Introduction

The CADMAX Solid Master Tutorial is a great way to learn about the benefits of feature-based parametric
solid modeling with CADMAX.  We have assembled several typical parts that you will be able to construct
using CADMAX Solid Master.  Each part should take between 20-40 minutes to complete.

The tutorial assumes that you already have some familiarity with CADMAX.  If you are unfamiliar with
CADMAX, review the Getting Started section first in CADMAX Help or in the CADMAX Users Manual. 
Here are several additional suggestions before getting started:  

! In the tutorial, there are several conventions that are used with text.  The text Draw > Circle > Center
Radius means to click on the Draw menu, hold the cursor over the Circle function until the Circle sub-
menu pops, then click on Center Radius.

! Most functions are available through drop-down menus and icon tool bars.  Throughout the tutorials
the written instructions tell you how to do things from the drop-down menus and the icons to the left
show you how to accomplish the same operation using icons.  The first icon is the icon to click on the
main tool bar, and the second indented icon is the icon on the vertical function bar.

   < Locate this icon on the top tool bar and click on it.

  < Then click on this icon on the vertical tool bar that pops up on the left side.

! When you see a statement that starts with the word “set”, this means you are to set a modifier value in
the currently displayed Function box.  For example, in the Line function box, you will see a -Connect?
modifier.   When you see the statement, “Set -Connect? to off”, this means you should set it off by
clicking on the word Connect if it isn’t already off.

! Sometimes you will be asked to set a specific value for a modifier. For example, in the Circle Function
box you will see a modifier called -Radius? with a combo box below it and a history arrow.  When you
see the statement, “Set -Radius? to .25”, you should click in the -Radius? text field and type in the
value or use the history arrow to select previous value. 

! When an instruction includes an arrow key (6 7 8 9) followed by a number, hold down the Ctrl key
before pressing the specified arrow.  For example, <Ctrl+6>1 means hold down the Ctrl key and press 6,
then release the keys and press 1.  After you type in the value, press Enter.

! Context sensitive prompts are available for each function in the message area at the bottom of the
screen.  Help is available buy pressing F1.
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! In the tutorial, we recommend when you should zoom in or out on the drawing to get better views of
your work.  In addition to our recommendations, you should feel free to use the View menu or the
Quick View tool bar to zoom around the drawing as you feel is appropriate.  Press F10 to go to previous
zooms or F11 to make a new zoom.

! To load a specified drawing, press F4 to Open a drawing or click on File > Open.  The drawings that
you will be asked to open are located in the \SAMPLES sub-folder under the folder that you installed
CADMAX. 
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Assembly-in-Place Modeling

In this tutorial you will create a basic fixture using Assembly-in-Place modeling.  Assembly-in-Place lets
you model multiple parts simultaneously in a single drawing, which gives you the ability to dynamically
create relationships between these parts as they are created.  Then as revisions are applied to the design,
associated parts will change automatically without the need for defining explicit variables.

You will also learn how to place parts into an assembly.  Additional parts can be placed from parts created
in the current drawing or from other drawings using parts libraries.
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Construct a Mounting Bracket 

In this section you are going to start with a initial part
called a mounting base and construct a bracket
directly on the mounting base.  You will start by
making a sketch of the bracket on the top face of the
base part.

1. Open the drawing mountingbase.cxd from
the \Samples\Fixture folder which is a
subfolder under the folder where you
installed CADMAX. 

2. Click on Edit > Feature Modeling or click on
the Feature Modeling icon on the Ribbon
bar to make sure you are in Modeling mode.

In the next series of features you will create a
mounting bracket which will be based on the
geometry in the mounting base.  By using
CADMAX’s assembly-in-place technology you
can easily establish relationships between the
parts.  If one part changes the other parts that
relate will automatically change with it.

3. Click on Edit > Sketch or click on the Sketch
icon on the ribbon bar.  This starts a new
sketch and displays the Work Plane function
box.

The Work Plane function box shows
different methods to locate the sketch plane,
depth, rotation and twist.

Once the work plane is defined, the Sketch
function bar will open and place you in the
Sketch Line function.  The Sketch function
bar contains many of the functions you will
use to draw and dimension a sketch.
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4. Set the -Method? to ‘On Face’,
-Adjustment? to ‘None’, and click on the top
face of the mounting base in the top or
isometric view.  Now, no matter which view
you work in, as you sketch your object, the
geometry will always be oriented to the top
view on the top face of the mounting base.

Note: You will find it easier if you zoom in on
the top view to for the next several steps. 
Use View > Zoom In or click on the Zoom In
icon on the vertical tool bar along the right
edge of the display and then click on two
point to define the area to zoom in on.

5. Click on Draw > Line.  Working in the top
view, sketch an object as shown.

Notice that CADMAX displays dynamic
construction lines as guides to help you
make vertical and horizontal lines. 

In particular, when you draw the second
horizontal line at the bottom of the sketch,
make sure you use the dynamic construction
line generated by the first horizontal line.  If
the dynamic construction line doesn’t
appear, wave over the first horizontal line
until the dynamic construction line appears. 
Using this procedure, it will only be
necessary to vertically dimension one line,
since both lines are implicitly linked.

6. Click on Draw > Circle > Center, Point.  Set
-Chain? ‘on’.

7. Starting with one of the four holes in the
mounting base, wave over the circle until
the center point pops up and click on the
center point.  Then drag the cursor until the
echo of the circle snaps to the diameter of
the circle in the mounting base and click to
place the circle.

This forces the diameter of the new circle to
always be equal to the diameter of the hole
in the mounting base.  If the diameter is
changed in the mounting base, then the
diameter of the hole in the mounting bracket
will automatically change too.



A

B
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8. Since -Chain? was set ‘on’, all ensuing
circles will have an equal diameter to the first
circle.  Place three more circles by waving
over each succeeding circle until the center
point pops up and then click on the center
point to place each circle.

Adding Dimensions 

Dimensions are used to make geometry the desired size.  CADMAX does not require that you add
dimensions before you extrude the model.  You can always return to the sketch and add dimensions
or change the sketch later in the design.  However, in this case, the size of the mounting bracket is
defined relative to the mounting base.  All edges are .25" in from the edge of the mounting base and
the overall height of the mounting bracket is 2.50".

1. Click on Dimension > Linear.

2. Click on the points A and B to define the
dimension shown. Drag the cursor to the
desired text position and click to place the
dimension.

Note: It may be necessary to set -Arrow
Position? to ‘inside’ or ‘outside’ to make the
dimension appear like the figures.

As you move the cursor to the right or left,
CADMAX calculates a vertical dimension or
as you move up and down a horizontal
distance is calculated.  Use the Ctrl key to
hold a particular dimension type when
attempting to place the text.

3. Type in .25 and press Enter.  This assigns a
value of .25" for the dimension and
automatically resizes the geometry according
to the assigned value.

You can always change this value at a later
time using the Equation function.

If the sketch geometry was constrained
correctly, both bottom horizontal lines
should have moved when the dimension
was changed.
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4. Repeat the above steps to place the
horizontal dimension.

5. Add the remaining dimensions shown.

Note: Once the dimensions are added, CADMAX reported in the Status Area at the bottom of
the display that the sketch was well-defined with the correct number of dimensions.  This
means that you have provided the correct dimensions and constraints to fully control this
sketch. Many of the constraints that are part of this sketch were invisible to you.  The
lines were constrained to be parallel and the angles were constrained to be perpendicular. 
These constraints were added as a function of using the dynamic construction lines. 
Without those constraints, it would have been necessary to add angular dimensions to
make the sketch well-defined. 

CADMAX does not require that each sketch be well-defined.  You can add only the
dimensions and constraints needed and continue modeling.  You can set your Sketch
Preferences to display the status of sketch geometry.  See Sketching in the CADMAX
Solid Master Help for more information on colors and display status.
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Extrude the Mounting Bracket 

The mounting bracket is a separate part from the mounting base.  When the sketch is extruded, use
Base to create a new solid.  Before the extrusion, you can assign a new part name and a different
geometry attribute to the part.

1. Click on Feature > Extrude Sketch or click
on the Extrude Sketch icon on the top tool
bar.

The Extrude dialog box appears so you can
specify the -Boolean Choices? to use.  Click
on ‘Base’. 

2. Set -Extrude Distance? to ‘.25' and -Extrude
Extent? to ‘Distance Above’.

3. On the Ribbon bar set the -Part Name? to
‘Mounting bracket’ and the -Geometry
Attribute? to ‘visible’.  

Hint: The Ribbon bar is the second
horizontal tool bar.  Type in the Part Name
and use the drop down arrow to choose a
geometry attribute.

A Geometry Attribute is used to control the
color, line style, and pen number for the
plotter.  The Geometry Attribute ‘visible’
makes the geometry orange.

4. The direction of the extrusion is defined by
the side of the sketch that you click on. 
Working in the front, side or isometric view,
click above the object, to create the initial
feature of the mounting bracket.

Note that the feature has been named
“mounting bracket” in the feature tree and
the geometry color should be orange.
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Test Part Associativity 

The next series of steps shows how the parts relate to each other.  As changes are made to the
variables used to define the mounting base, the mounting bracket will change with it, keeping the
relationships that were established between the parts.  This is the power behind CADMAX’s
assembly-in-place construction.  As a function of the design process, geometry between parts
relate automatically for relationships that don’t have to be explicitly defined.

1. In the Feature tree double-click the
Mounting base feature to display the
Variables dialog box or right click the
Mounting Base feature to display the pop
up menu and click Edit Variables. 

2. The Variables dialog box shows the
variables that were used to define the initial
mounting base feature.  d1 and d2 specify
the length and width.  Change the value of
d1 to 12, by clicking on the 9.000 and then
enter the new value.  It is not necessary to
press Enter or type in the decimal or trailing 
zeros.

3. Click Feature > Rebuild Model.

Both parts rebuild based on the new value
for d1.  Notice that the mounting bracket
maintained its original relationship with the
mounting base.

4. Let’s make a couple more changes.

Double-click on Cut1 and change d5 and d6
to 2.  Then double-click on Cut2 and change
diam1 to .75.



Wave over edge until
work plane echo
snaps to the
midpoint of the line

Work plane echo
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5. Click Feature > Rebuild Model.  Note how
the mounting bracket is driven by the
changes to the features of the mounting
base.

6. Change the mounting base back to its
original dimensions.  Double-click on
Mounting base and change d1 to 9.  Double-
click on Cut1 and change d5 and d6 to .75. 
Double-click on Cut2 and change diam1 to
.25.

7. Click Feature > Rebuild.

8. Right-click on any of the features in the
Feature Tree that are bold, and if Show is
checked, click Show to uncheck it and make
the sketch no longer display.

Complete the Mounting Bracket 

In the next series of steps you will add the clip
and chamfer to the mounting bracket.

1. Click on Edit > Sketch or click on the Sketch
icon on the ribbon bar to start a new sketch.

2. In the Work Plane function box, set the
-Method? to ‘Right’, -Adjustment? to
‘None’.  Click on the midpoint snap button
in the snap tool bar on the right.

3. In the isometric view, wave the cursor over
the back edge until the work plane snaps to
the midpoint of the line.  Click to place the
work plane.  This sets the work plane to be
centered on the object and aligned to the
side view.

4. Click on Draw > Sketch. 

5. Working in the side view, add three lines as
shown.  Start by waving the cursor over
point B, to make the vertical dynamic
construction line display.  Then click on
points A, B, C, and D.  Make sure that point
C is only along the horizontal line and



A

D
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doesn’t snap to any pop up end points,
otherwise point C will be constrained to that
location.  Also, make sure point D doesn’t
snap to any dynamic construction lines.

6. Click on Draw > Arc >3 Points .  Click on
point A as the start of the arc and point D as
the end of the arc, then drag the cursor up
and click to place the arc.

7. Click on Draw > Constrain > Tangent.  Click
on the arc, then click on the vertical line at
point A to make the arc tangent to the line.

8. Click on Dimension > Radius.  Set -# Auto
Decimal Places? to ‘3'.

9. Wave the cursor over the arc until it turns
red and an echo of the radial dimension is
displayed.  Click on the arc, drag the cursor
to locate the text, and click to place the radial
dimension.

10. Type .625 and press Enter to set the radius
of the hole to .625.

11. Click on Draw > Circle > Center, Point.  
Wave the cursor over the arc until the center
point pops up.  Click on the center point and
drag the cursor out and click to create a
circle.

12. Click on Dimension > Radius.

13. Wave the cursor over the circle until it turns
red and an echo of the radial dimension is
displayed.  Click on the circle, drag the
cursor to locate the text, and click to place
the radial dimension.
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14. Type .75 and press Enter to set the diameter
of the hole to .75.

15. Click on Dimension > Linear.  Add the
dimensions shown in the figure to the right.
After you place the dimension text, just type
in the desired size and press Enter.  

As a reminder, you can freeze a dimension to
horizontal or linear by holding down the Ctrl
key before you place the text.

16. Click on Dimension > Angle.  Add the
angular dimension shown in the figure to the
right by clicking on the two lines to measure
the angle between. After you place the
dimension text, just type in the desired angle
and press Enter.  

Note: Check the Status Area.  CADMAX
report that the sketch is well-defined.  This
means that the correct number of dimensions
and constraints have been specified.

17. Click on Feature > Extrude Sketch to
display the Extrude function box.  Select
Boss as the type of extrude.  Boss means to
add the new feature to the specified solids.



Select 1/4" line

Select 1/4" line
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18. In the Extrude Boss function box, set:

• -Target Solids? to ‘All’
• -Extrude Distance? to ‘25'.
• -Extrude Extent? to ‘Midplane’, which

will extrude the profile one-half the
-Extrude Distance? in both directions.

19. Click anywhere inside one of the views to
extrude the profile.

20. Zoom in on the isometric view and change
the view to be hidden-dashed.

21. Click Select > Select Element and click on
the two short vertical edges shown in the
figure to the right. 

Notice that the edges and surfaces highlight
in red as you move the cursor over them
identifying which item will be selected. 
Make sure only the edge is highlighted
when you click and not the entire surface.

22. Click on Feature > Chamfer, Fixed.  The
Chamfer function box appears.

23. Set -Radius? to ‘.5' and click Finish to apply
the chamfer feature to the selected edges.
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Instance the Mounting Bracket 

In the next series of steps you will insert an
instance of the mounting bracket on the
opposite side of the mounting base.  

Throughout the process of inserting parts
into the assembly you should make use of the
zoom functions to get a better view.  Zoom
and Previous are the top two icons on the
vertical tool bar along the right edge of the
display.  You will find it easiest t work in the
isometric view with a hidden dashed picture.

1. Click on Tools > Parts or click on the Parts
icon on the main tool bar.

2. In the Parts dialog box make sure -Contents
of? is set to ‘Pool’.  When -Contents of? is
set to ‘pool’, the Parts dialog show the parts
in the current drawing, which in this case are
the mounting base and mounting bracket. 

3. Click on mounting bracket and then click on
Assemble to begin the process of placing
another instance of the mounting bracket
into the drawing.



Mounting bracket
instance
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4. An instance of the mounting bracket is
attached to the cursor and the Initial Place
dialog box is displayed.  Drag the mounting
bracket into the isometric view and put it
down towards the rear of the mounting
base.  This is just an initial placement.  In the
following steps you will use additional
functions to position the mounting bracket
precisely on the mounting base.  When you
place the instance, it will turn violet.

Hint: It will be easier to work if you zoom
into the isometric view and set it to be
hidden-dashed.  

5. Once initial placement has been completed,
the Orient From dialog box is displayed.  
Use Orient From to define the work plane
and origin of the current instance that will be
used to position it on the assembly.  The
plane that is selected here will be matched to
a plane on the assembly in the next step.

Set -Method? to ‘On Edge’.  As you wave
over the instance of the mounting bracket,
the work plane echo shows the origin and
the orientation of the work plane.  

When using ‘On Edge’, the work plane is
oriented to a specific face which is defined
by the edges of the face.  If two planes are
shared by an edge, the plane that is defined
is determined by the side of the line that the
cursor is positioned. 



. . . to this hole on the
mounting base.

Match this hole on the
mounting bracket . . .
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6. In order to position the mounting bracket, it
will have to be rotated 180 degrees from its
current position.  You will accomplish this
by anchoring matching holes between the
mounting base and the mounting bracket,
and then pivot the mounting bracket into
place to a second set of matching holes.

Wave the cursor over the mounting bracket
instance until the work plane echo snaps to
the matching hole on the bottom of the
mounting bracket and then click to set the
work plane to this location.

7. As soon as the Orient From work plane is
defined, the Orient To dialog box is
displayed.  Use Orient To to identify the
plane that will match to the Orient From
plane.  Only planes on the assembly can be
used with Orient To. 

Wave the cursor over the mounting base 
until the work plane echo snaps to the
matching hole on the top of the mounting
base and then click to position the
mounting bracket to this location. 



Match to this hole on
the mounting base.

Mounting bracket instance
with planes matched up.

. . . to this hole on the
mounting base.

Pivot from this hole on
the mounting bracket . .
.
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8. Once the work planes are matched, you are
ready to pivot the mounting bracket into
place.  Parts are pivoted about their origin.
Click on Pivot in the Align From dialog box. 
Then click on the hole in the mounting
bracket that will pivot to the mounting base,
then click on the hole in the mounting base
to pivot to.

9. Click Finish to complete placement of the
mounting bracket instance.

10. Save your work.
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Adding Parts from Other Drawings 

In next section you will add an insert between the two
mounting brackets.  The insert is a part that comes from a
separate drawing.  Parts are registered with a Part
Libraries.

1. Click on Tools > Parts or click on the Parts
icon on the main tool bar.

2. In the Parts dialog box set -Contents of? to
‘Library’.  The Parts dialog box expands to
show the Part libraries.  Locate ‘assy2' from
the list of libraries and click on the library
name.

When -Contents of? is set to ‘library’, the
Parts dialog box expands to show a list of
part libraries.  In this case the parts in the
assy2 library are insert and sh2575. 

3. Click on insert and then click on Assemble..
to begin the process of placing an instance
of the insert into the drawing.
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4. An instance of the insert is attached to the
cursor and the Initial Place dialog box is
displayed.  Drag the part into the work area
and click to put it down.   This is just an
initial placement.  In the following steps you
will use additional functions to position the
insert precisely on the fixture assembly.  The
violet color is used to denote that this is the
part being added to the assembly.

5. Once initial placement has been completed,
the Orient From dialog box is displayed.  
Use Orient From to define the work plane
and origin of the part that will be used to
position it on the assembly.  The plane that
is selected here will be matched to a plane
on the assembly in the next step.

Set -Method? to ‘On Edge’.  As you wave
over the instance of the insert, the work
plane echo shows the origin and the
orientation of the work plane to be defined.  

When using ‘On Edge’, the work plane is
oriented to a specific face which is defined
by the edges of the face.  If two planes are
shared by an edge, the plane that is defined
is determined by the side of the line over
which the cursor is positioned. 

6. On the insert the Orient From plane is going
to be the plane on the end of the cylinder
with the origin as the center of the cylinder. 

Wave the cursor over the insert instance
until the work plane echo snaps to the center
of the cylinder as shown and then click to
set the work plane to this location.



Use the center of the
mounting bracket hole
as the Orient To
workplane.

Initial placement of the
insert using the Orient From
and Orient To workplanes
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7. As soon as the Orient From work plane is
defined, the Orient To dialog box is
displayed.  Use Orient To to identify the
plane on the assembly that will match to the
Orient From plane.  Only planes on the
assembly can be used with Orient To. 

Wave the cursor over the assembly  until
the work plane echo snaps to the matching
hole on the top of the mounting bracket
and then click to position the insert to this
location. 

8. Once the initial placement of the insert has
been completed, you are ready to put the
part in its final position.  The Align From
dialog box contains a number of different
operations that can be applied to the part. 
In this case, you will move the insert along
one axis to slide the part further into the
mounting bracket holes using Offset.
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Choosing the offset axis is determined by
the work plane used to position the part. 
The work plane locator echo defines the axis.

As shown, the insert is going to be offset in
the negative z direction by a distance of ‘3'.

Set -Offset Z? to ‘-3.0'.  A red echo previews
the offset position of the part. 

Offset is used to move the part being added
to the assembly a specific distance along
one axis.  The Move functions are used to
move the part along an axis by choosing a
pick up point on the part and a put down
point on the assembly.  The part then move
the distance between the two points in the
specified axis.

9. Click Finish to complete placement of the
insert instance.
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Insert Socket Head Screws 

In next section you will complete the fixture by adding
socket head screws to secure the mounting bracket to
the mounting base.  The socket head screw comes from a
separate drawing. 

1. Click on Tools > Parts or click on the Parts
icon on the main tool bar.

2. In the Parts dialog box set -Contents of? to
‘Library’.  The Parts dialog box expands to
show the Part libraries.  Locate ‘assy2' from
the list of libraries and click on the library
name.

When -Contents of? is set to ‘library’, the
Parts dialog box expands to show a list of
part libraries.  In this case the parts in the
assy2 library are insert and sh2575. 

3. Click on sh2575 and then click on
Assemble.. to begin the process of placing
an instance of the first instance of sh2575
into the drawing.

4. An instance of sh2575 is attached to the
cursor and the Initial Place dialog box is
displayed.  Check -Multiple Copies?,  set -
Orientation? to ‘Top’, and click to perform
the initial placement of the socket head
screw.  When you place the instance, it will
turn violet.

Note: The Orientation option helps you to
visually relate the part to the assembly, but
in no way controls its final position.   

Note: When Multiple Copies is checked, a
new instance of the part is automatically
inserted when Finish is clicked, using the
original Orient From work plane.
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5. Once initial placement has been completed,
the Orient From dialog box is displayed.  
Use Orient From to define the work plane
and origin of the part that will be used to
position it on the assembly.  The plane that
is selected here will be matched to a plane
on the assembly in the next step.

Set -Method? to ‘On Edge’.  As you wave
over sh2575, the work plane echo shows the
origin and the orientation of the work plane
to be defined.  

Note: When using ‘On Edge’, the work
plane is oriented to a specific face which is
defined by the edges of the face.  If two
planes are shared by an edge, the plane that
is defined is determined by the side of the
line that the cursor is positioned. 

6. The Orient From plane is going to be top of
the cylinder where it meets the socket head
with the origin as the center of the cylinder. 

Wave the cursor over the sh2575 part until
the work plane echo snaps to the center of
the cylinder as shown and then click to set
the work plane to this location.

7. The Orient To dialog box is displayed.  Use
it to identify the plane on the assembly that
will match to the Orient From plane.  Only
planes on the assembly can be used with
Orient To. 

Wave the cursor over the assembly  until the
work plane echo snaps to one of the screw
holes on the mounting bracket and then
click to position the socket head screw to
this location.   If the part position is mated
incorrectly, then click on -Mate? to reverse
the mating direction before clicking on the
put down point in the assembly.
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8. No additional steps are needed to position
the socket head screw.  Click Finish in the
Align From dialog box to complete insertion
of the first instance of the socket head
screw. 

9. Since -Multiple Copies? was checked, a new
instance of the part is inserted into the
drawing and the Align To dialog box is
displayed.  It is not necessary to make an
initial placement or to define an Orient From
work plane.  CADMAX reuses the original
Orient From work plane, so now all you have
to do is place the part.

Wave the cursor over the assembly  until the
work plane echo snaps to one of the screw
holes on the mounting bracket and then
click to position the socket head screw to
this location.   If the part position is mated
incorrectly, then click on -Mate? to reverse
the mating direction.

10. Click Finish in the Align From dialog box to
complete insertion of the next instance of the
socket head screw. 

11. Continue inserting additional instances of
the socket head screw until all eight parts are
in place.  Before you click Finish on the last
screw uncheck -Multiple Copies? to stop
adding additional copies of the socket head
screw.  Otherwise the function will keep
looping making it confusing for you.

12. This completes the fixture.  Save your work.


